WooCommerce Subscriptions <= 5.1.2 - Missing Authorization to Insecure Direct Object Reference

Authorization Bypass Through User-Controlled Key
CVE CVE-2023-35914
CVSS 6.5 (Medium)
Publicly Published June 19, 2023
Last Updated September 19, 2023
Researcher Rafie Muhammad - Patchstack


The WooCommerce Subscriptions plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on an unknown unction in versions up to, and including, 5.1.2. This makes it possible for unauthenticated attackers to access or modify information by passing in a user-conttrolled parameter.



Vulnerability Details for WooCommerce Subscription

Software Type Plugin
Software Slug woocommerce-subscriptions
Patched? Yes
Remediation Update to version 5.1.3, or a newer patched version
Affected Version
  • <= 5.1.2
Patched Version
  • 5.1.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.