SuperFaktura WooCommerce <= 1.40.3 - Authenticated (Subscriber+) Blind Server-Side Request Forgery

Server-Side Request Forgery (SSRF)
CVE CVE-2024-1758
CVSS 5.4 (Medium)
Publicly Published February 23, 2024
Last Updated April 30, 2024
Researcher Lucio Sá


The SuperFaktura WooCommerce plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 1.40.3 via the wc_sf_url_check function. This makes it possible for authenticated attackers, with subscriber-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services. CVE-2024-32803 appears to be a duplicate of this issue.



Vulnerability Details for SuperFaktura WooCommerce

Software Type Plugin
Software Slug woocommerce-superfaktura (view on
Patched? Yes
Remediation Update to version 1.40.4, or a newer patched version
Affected Version
  • <= 1.40.3
Patched Version
  • 1.40.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.