Wholesale Suite <= 2.1.5 - Missing Authorization to Plugin Settings Change

Missing Authorization
CVE CVE-2022-34344
CVSS 4.3 (Medium)
Publicly Published February 27, 2023
Last Updated January 22, 2024
Researcher Dave Jong - Patchstack


The Wholesale Suite plugin for WordPress is vulnerable to unauthorized data modification due to a missing capability check on the edit_wholesale_role function in versions up to, and including, 2.1.5. This makes it possible for authenticated attackers with subscriber-level privileges to change the plugin's settings.



Vulnerability Details for Wholesale Suite – WooCommerce Wholesale Prices, B2B, Catalog Mode, Order Form, Wholesale User Roles, Dynamic Pricing & More

Software Type Plugin
Software Slug woocommerce-wholesale-prices (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.1.6, or a newer patched version
Affected Version
  • <= 2.1.5
Patched Version
  • 2.1.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.