WooCommerce <= 3.4.4 - Authenticated PHP Object Injection

Deserialization of Untrusted Data
CVSS 6.6 (Medium)
Publicly Published August 29, 2018
Last Updated January 30, 2023


The WooCommerce plugin for WordPress is vulnerable to PHP Object Injection by users with access to edit attributes in versions up to, and including 3.4.4.



1 affected software package

Software Type Plugin
Software Slug woocommerce (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.4.5, or a newer patched version
Affected Version
  • < 3.4.5
Patched Version
  • 3.4.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.