WooCommerce <= 3.4.5 - WooCommerce File Deletion

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2018-20714
CVSS 7.2 (High)
Publicly Published November 6, 2018
Last Updated January 30, 2023
Researchers Simon Scannell
Karim El Ouerghemmi
Slavco Mihajloski


The logging system of the Automattic WooCommerce plugin before 3.4.6 for WordPress is vulnerable to a File Deletion vulnerability. This allows deletion of woocommerce.php, which leads to certain privilege checks not being in place, and therefore a shop manager can escalate privileges to admin.



Vulnerability Details for WooCommerce

Software Type Plugin
Software Slug woocommerce (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.4.6, or a newer patched version
Affected Version
  • < 3.4.6
Patched Version
  • 3.4.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.