WooCommerce <= 6.2.0 - Incorrect Authorization Checks on REST API Endpoints

5.4
Improper Authorization
CVE CVE-2022-0775
CVSS 5.4 (Medium)
Publicly Published February 22, 2022
Last Updated February 6, 2024
Researcher Krzysztof Zając - CERT PL

Description

The WooCommerce plugin for WordPress is vulnerable to authorization bypass due to an insufficient capability check on the /wc/v2/products/ REST API in versions up to, and including, 6.2.0. This makes it possible for authenticated attackers with minimal permissions such as a subscriber to delete, edit, and read arbitrary comments and reviews.

References

Share

1 affected software package

Software Type Plugin
Software Slug woocommerce (view on wordpress.org)
Patched? Yes
Remediation Update to version 6.2.1, or a newer patched version
Affected Version
  • <= 6.2.0
Patched Version
  • 6.2.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation