WooCommerce <= 6.2.0 - Path Traversal via Tax Importer

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVSS 7.2 (High)
Publicly Published February 22, 2022
Last Updated January 30, 2023


The WooCommerce plugin for WordPress is vulnerable to path traversal via the 'file_url' parameter found in the importers functionality in versions up to, and including, 6.2.0. This makes it possible for authenticated attackers, with high-level permissions such as an administrator, to access files outside of the intended directory when performing an import.



1 affected software package

Software Type Plugin
Software Slug woocommerce (view on wordpress.org)
Patched? Yes
Remediation Update to version 6.2.1, or a newer patched version
Affected Version
  • <= 6.2.0
Patched Version
  • 6.2.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.