WooCommerce <= 7.0.0 - Authenticated(Shop Manager+) Sensitive Information Exposure

Information Exposure
CVSS 4.9 (Medium)
Publicly Published September 11, 2023
Last Updated January 22, 2024
Researcher David Anderson


The WooCommerce plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 7.0.0. This can allow authenticated attackers with Shop Manager privileges or above to extract sensitive user metadata including session tokens.



Vulnerability Details for WooCommerce

Software Type Plugin
Software Slug woocommerce (view on wordpress.org)
Patched? Yes
Remediation Update to version 7.0.1, or a newer patched version
Affected Version
  • <= 7.0.0
Patched Version
  • 7.0.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.