Woodmart Core <= 1.0.36 - PHP Object Injection

Deserialization of Untrusted Data
CVE CVE-2023-32242
CVSS 9.8 (Critical)
Publicly Published May 11, 2023
Last Updated May 15, 2023
Researcher Dave Jong - Patchstack


The Woodmart Core plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 1.0.36 via deserialization of untrusted input. This allows unauthenticated attackers to inject a PHP Object. If a POP chain is present in the vulnerable plugin, an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.



1 affected software package

Software Type Plugin
Software Slug woodmart-core
Patched? Yes
Remediation Update to version 1.0.37, or a newer patched version
Affected Version
  • <= 1.0.36
Patched Version
  • 1.0.37

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.