ShopLentor <= 2.8.8 - Missing Authorization to WordPress Option Modification

Missing Authorization
CVE CVE-2024-4566
CVSS 7.1 (High)
Publicly Published May 20, 2024
Last Updated May 21, 2024
Researcher TheGreatLol - student


The ShopLentor plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the ajax_dismiss function in all versions up to, and including, 2.8.8. This makes it possible for authenticated attackers, with contributor-level access and above, to set arbitrary WordPress options to "true". NOTE: This vulnerability can be exploited by attackers with subscriber- or customer-level access and above if (1) the WooCommerce plugin is deactivated or (2) access to the default WordPress admin dashboard is explicitly enabled for authenticated users.



Vulnerability Details for ShopLentor – WooCommerce Builder for Elementor & Gutenberg +12 Modules – All in One Solution (formerly WooLentor)

Software Type Plugin
Software Slug woolentor-addons (view on
Patched? Yes
Remediation Update to version 2.8.9, or a newer patched version
Affected Version
  • <= 2.8.8
Patched Version
  • 2.8.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.