APIExperts Square for WooCommerce <= 4.2.9 - Reflected Cross-Site Scripting

6.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-27959
CVSS 6.1 (Medium)
Publicly Published March 13, 2024
Last Updated March 20, 2024
Researcher stealthcopter

Description

The APIExperts Square for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting in versions up to, and including, 4.2.9 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Share

Vulnerability Details for WC Shop Sync – Integrate Square and WooCommerce for Seamless Shop Management

Software Type Plugin
Software Slug woosquare (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.3, or a newer patched version
Affected Version
  • <= 4.2.9
Patched Version
  • 4.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation