WordPress Multisite User Sync/Unsync (Premium) <= 2.1.1 Reflected Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-25038
CVSS 6.1 (Medium)
Publicly Published February 7, 2022
Last Updated January 22, 2024
Researcher Asif Nawaz Minhas - Patchstack Alliance


The WordPress Multisite User Sync/Unsync WordPress plugin before 2.1.2 does not sanitise and escape the wmus_source_blog and wmus_record_per_page parameters before outputting them back in attributes, leading to Reflected Cross-Site Scripting issues



Vulnerability Details for WordPress Multisite User Sync/Unsync (Premium)

Software Type Plugin
Software Slug wordpress-multisite-user-sync
Patched? Yes
Remediation Update to version 2.1.2, or a newer patched version
Affected Version
  • <= 2.1.1
Patched Version
  • 2.1.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.