Hustle <= 7.8.3 - Sensitive Information Exposure via Exposed Hubspot API Keys

Insufficiently Protected Credentials
CVE CVE-2024-0368
CVSS 8.6 (High)
Publicly Published March 12, 2024
Last Updated March 13, 2024
Researcher Sean Murphy


The Hustle – Email Marketing, Lead Generation, Optins, Popups plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 7.8.3 via hardcoded API Keys. This makes it possible for unauthenticated attackers to extract sensitive data including PII.



Vulnerability Details for Hustle – Email Marketing, Lead Generation, Optins, Popups

Software Type Plugin
Software Slug wordpress-popup (view on
Patched? Yes
Remediation Update to version 7.8.4, or a newer patched version
Affected Version
  • <= 7.8.3
Patched Version
  • 7.8.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.