WP 2FA <= 2.5.0 - Insecure Direct Object Reference to Arbitrary Email Sending

Authorization Bypass Through User-Controlled Key
CVE CVE-2023-6506
CVSS 4.3 (Medium)
Publicly Published January 2, 2024
Last Updated January 22, 2024
Researcher Ulyses Saicha


The WP 2FA – Two-factor authentication for WordPress plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 2.5.0 via the send_backup_codes_email due to missing validation on a user controlled key. This makes it possible for subscriber-level attackers to email arbitrary users on the site.



Vulnerability Details for WP 2FA – Two-factor authentication for WordPress

Software Type Plugin
Software Slug wp-2fa (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.6.0, or a newer patched version
Affected Version
  • <= 2.5.0
Patched Version
  • 2.6.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.