WP 2FA – Two-factor authentication for WordPress <= 2.2.0 - Reflected Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-1527
CVSS 6.1 (Medium)
Publicly Published May 6, 2022
Last Updated January 22, 2024
Researcher Utkarsh Agrawal


The WP 2FA WordPress plugin before 2.2.1 does not sanitize and escape a parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting issue.



Vulnerability Details for WP 2FA – Two-factor authentication for WordPress

Software Type Plugin
Software Slug wp-2fa (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.2.1, or a newer patched version
Affected Version
  • <= 2.2.0
Patched Version
  • 2.2.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.