WP 2FA – Two-factor authentication for WordPress <= 2.5.0 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-6520
CVSS 4.3 (Medium)
Publicly Published January 2, 2024
Last Updated January 22, 2024
Researcher Ulyses Saicha


The WP 2FA – Two-factor authentication for WordPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.5.0. This is due to missing or incorrect nonce validation on the send_backup_codes_email function. This makes it possible for unauthenticated attackers to send emails with arbitrary content to registered users via a forged request granted they can trick a site administrator or other registered user into performing an action such as clicking on a link. While a nonce check is present, it is only executed if a nonce is set. By omitting a nonce from the request, the check can be bypassed.



Vulnerability Details for WP 2FA – Two-factor authentication for WordPress

Software Type Plugin
Software Slug wp-2fa (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.6.0, or a newer patched version
Affected Version
  • <= 2.5.0
Patched Version
  • 2.6.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.