Analytify Dashboard <= 5.1.1 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-47841
CVSS 4.3 (Medium)
Publicly Published November 20, 2023
Last Updated November 24, 2023
Researcher Abdi Pranata


The Analytify – Google Analytics Dashboard For WordPress (GA4 analytics made easy) plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 5.1.1. This is due to missing or incorrect nonce validation on the send_analytics_email function. This makes it possible for unauthenticated attackers to send a feedback email usually sent on uninstall with admin consent via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug wp-analytify (view on
Patched? Yes
Remediation Update to version 5.2.0, or a newer patched version
Affected Version
  • <= 5.1.1
Patched Version
  • 5.2.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.