WordPress Automatic <= 3.94.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via autoplay Parameter

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-4849
CVSS 6.4 (Medium)
Publicly Published May 17, 2024
Last Updated May 18, 2024
Researcher haidv35 - VCS


The WordPress Automatic Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘autoplay’ parameter in all versions up to, and including, 3.94.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for WordPress Automatic Plugin

Software Type Plugin
Software Slug wp-automatic
Patched? Yes
Remediation Update to version 3.95.0, or a newer patched version
Affected Version
  • <= 3.94.0
Patched Version
  • 3.95.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.