WP BrowserUpdate <= 4.5 - Authenticated (Admin+) Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-28690
CVSS 6.1 (Medium)
Publicly Published April 26, 2023
Last Updated January 22, 2024
Researcher qilin_99


The WP BrowserUpdate plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the multiple parameters in versions up to, and including, 4.5 due to insufficient input sanitization and output escaping. Combined with a Cross-Site Request Forgery vulnerability in versions <= 4.4.1, this makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute if they can successfully trick a user into performing an action such as clicking on a link. In version 4.5, this issue is only exploited by authenticated administrative users.



Vulnerability Details for WP BrowserUpdate

Software Type Plugin
Software Slug wp-browser-update (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.6, or a newer patched version
Affected Version
  • <= 4.5
Patched Version
  • 4.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.