WP Compress – Image Optimizer <= 6.11.10 - Missing Authorization to Unauthenticated CDN Modification

7.5
Missing Authorization
CVE CVE-2024-1934
CVSS 7.5 (High)
Publicly Published March 21, 2024
Last Updated April 9, 2024
Researcher Krzysztof Zając - CERT PL

Description

The WP Compress – Image Optimizer plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'wps_local_compress::__construct' function in all versions up to, and including, 6.11.10. This makes it possible for unauthenticated attackers to reset the CDN region and set a malicious URL to deliver images.

References

Share

Vulnerability Details for WP Compress – Image Optimizer [All-In-One]

Software Type Plugin
Software Slug wp-compress-image-optimizer (view on wordpress.org)
Patched? Yes
Remediation Update to version 6.11.11, or a newer patched version
Affected Version
  • <= 6.11.10
Patched Version
  • 6.11.11

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation