WP Content Pilot – Autoblogging & Affiliate Marketing Plugin <= 1.3.3 - Authenticated (Contributor+) Content Injection

Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')
CVE CVE-2023-45053
CVSS 4.3 (Medium)
Publicly Published October 3, 2023
Last Updated January 22, 2024
Researcher Abdi Pranata


The WP Content Pilot plugin for WordPress is vulnerable to Arbitrary Content Injection in versions up to, and including, 1.3.3. This vulnerability makes it possible for authenticated attackers, with contributor access or higher to inject new content onto the website, possibly through the manipulation of posts to create new web pages, spam, or phishing.



1 affected software package

Software Type Plugin
Software Slug wp-content-pilot (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.3.4, or a newer patched version
Affected Version
  • <= 1.3.3
Patched Version
  • 1.3.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.