WP Courses LMS <= 3.2.3 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVSS 4.3 (Medium)
Publicly Published November 14, 2023
Last Updated January 22, 2024


The WP Courses LMS – Online Courses Builder, eLearning Courses, Courses Solution, Education Courses plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.2.3. This is due to missing nonce validation on several functions hooked via AJAX in the ~/ajax/ajax-lesson-order.php file. This makes it possible for unauthenticated attackers to to perform several actions such as adding, deleting and renaming lesson modules via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug wp-courses (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.2.4, or a newer patched version
Affected Version
  • <= 3.2.3
Patched Version
  • 3.2.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.