WP Custom Admin Interface <= 7.28 - Authenticated (Administrator+) PHP Object Injection

Deserialization of Untrusted Data
CVE CVE-2022-4043
CVSS 7.2 (High)
Publicly Published December 13, 2022
Last Updated January 22, 2024
Researcher thinhnguyen1337


The WP Custom Admin Interface plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 7.28, via deserialization of untrusted input in the northernbeacheswebsites_information and wp_custom_admin_interface_import_settings functions. This allows administrator-level attackers to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code. The vulnerability is patched by setting allowed_classes. While this makes the vulnerability more or less unexploitable, PHP recommends not passing untrusted input to the unserialize function.



1 affected software package

Software Type Plugin
Software Slug wp-custom-admin-interface (view on wordpress.org)
Patched? Yes
Remediation Update to version 7.29, or a newer patched version
Affected Version
  • <= 7.28
Patched Version
  • 7.29

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.