WP Dark Mode <= 4.0.7 - Authenticated (Subscriber+) Local File Inclusion via 'style'

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2023-0467
CVSS 8.8 (High)
Publicly Published March 6, 2023
Last Updated January 22, 2024
Researcher Alex Sanford


The WP Dark Mode plugin for WordPress is vulnerable to Local File Inclusion in versions up to, and including, 4.0.7 via the 'style' shortcode attribute. This allows authenticated attackers, with subscriber-level permissions and above, to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included. This only affects installations where the traversal of non-existent directories is allowed or when chained with another vulnerability that allows for the creation of arbitrary directories.



Vulnerability Details for WP Dark Mode – WordPress Dark Mode Plugin for Improved Accessibility, Dark Theme, Night Mode, and Social Sharing

Software Type Plugin
Software Slug wp-dark-mode (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.0.8, or a newer patched version
Affected Version
  • <= 4.0.7
Patched Version
  • 4.0.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.