WP Data Access <= 4.3.1 - Admin+ SQL Injection

7.2
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2021-24866
CVSS 7.2 (High)
Publicly Published November 8, 2021
Last Updated January 18, 2023
Researcher ZhongFu Su

Description

The WP Data Access WordPress plugin before 5.0.0 does not properly sanitise and escape the backup_date parameter before using it a SQL statement, leading to a SQL injection issue and could allow arbitrary table deletion

References

Share

Vulnerability Details for WP Data Access

Software Type Plugin
Software Slug wp-data-access (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.0.0, or a newer patched version
Affected Version
  • <= 4.3.1
Patched Version
  • 5.0.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation