WP Data Access <= 5.3.7 - Authenticated (Subscriber+) Privilege Escalation

Incorrect Privilege Assignment
CVE CVE-2023-1874
CVSS 7.5 (High)
Publicly Published April 6, 2023
Last Updated April 14, 2023
Researcher Chloe Chamberland - Wordfence


The WP Data Access plugin for WordPress is vulnerable to privilege escalation in versions up to, and including, 5.3.7. This is due to a lack of authorization checks on the multiple_roles_update function. This makes it possible for authenticated attackers, with minimal permissions such as a subscriber, to modify their user role by supplying the 'wpda_role[]' parameter during a profile update. This requires the 'Enable role management' setting to be enabled for the site.



1 affected software package

Software Type Plugin
Software Slug wp-data-access (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.3.8, or a newer patched version
Affected Version
  • <= 5.3.7
Patched Version
  • 5.3.8

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.