Discussion Board <= 2.4.8 - Authenticated (Subscriber+) Content Injection

Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')
CVE CVE-2023-39161
CVSS 5.4 (Medium)
Publicly Published July 26, 2023
Last Updated January 22, 2024
Researcher Abdi Pranata


The Discussion Board plugin for WordPress is vulnerable to Content Injection in versions up to, and including, 2.4.8 via the discussion feature. This vulnerability makes it possible for authenticated attackers, subscribers and higher, to inject new content onto the website, through the manipulation of posts to create new web pages, spam, or phishing.



1 affected software package

Software Type Plugin
Software Slug wp-discussion-board (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.4.9, or a newer patched version
Affected Version
  • <= 2.4.8
Patched Version
  • 2.4.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.