WP Downgrade <= 1.2.2 - Admin+ Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-1001
CVSS 4.8 (Medium)
Publicly Published March 22, 2022
Last Updated January 22, 2024
Researcher Taurus Omar


The WP Downgrade WordPress plugin before 1.2.3 only perform client side validation of its "WordPress Target Version" settings, but does not sanitise and escape it server side, allowing high privilege users such as admin to perform Cross-Site attacks even when the unfiltered_html capability is disallowed



1 affected software package

Software Type Plugin
Software Slug wp-downgrade (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.2.3, or a newer patched version
Affected Version
  • < 1.2.3
Patched Version
  • 1.2.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.