WP Dummy Content Generator <= 3.1.2 - Missing Authorization

Missing Authorization
CVE CVE-2024-24805
CVSS 5.3 (Medium)
Publicly Published February 2, 2024
Last Updated February 5, 2024
Researcher Huynh Tien Si


The WP Dummy Content Generator plugin for WordPress is vulnerable to unauthorized modification of data due to missing capability check son the wp_dummy_content_generatorDeletePosts() and wp_dummy_content_generatorAjaxGenPosts() functions in versions up to, and including, 3.1.2. This makes it possible for unauthenticated attackers to delete and generate posts.



Vulnerability Details for WP Dummy Content Generator

Software Type Plugin
Software Slug wp-dummy-content-generator (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.1.3, or a newer patched version
Affected Version
  • <= 3.1.2
Patched Version
  • 3.1.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.