WP EasyPay – Square for WordPress <= 3.2.0 - Cross-Site Request Forgery Bypass

Cross-Site Request Forgery (CSRF)
CVE CVE-2021-4411
CVSS 4.3 (Medium)
Publicly Published July 5, 2021
Last Updated July 12, 2023
Researcher Jerome Bruandet - NinTechNet


The WP EasyPay – Square for WordPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.2.0. This is due to missing or incorrect nonce validation on the wpep_download_transaction_in_excel() function. This makes it possible for unauthenticated attackers to trigger a transactions download via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for WP EasyPay – Square for WordPress

Software Type Plugin
Software Slug wp-easy-pay (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.2.3, or a newer patched version
Affected Version
  • <= 3.2.0
Patched Version
  • 3.2.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.