WP EasyCart <= 5.4.10 - Authenticated (Administrator+) SQL Injection via 'orderby'

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2023-3023
CVSS 7.2 (High)
Publicly Published June 8, 2023
Last Updated January 22, 2024
Researcher Alex Thomas - Wordfence


The WP EasyCart plugin for WordPress is vulnerable to time-based SQL Injection via the ‘orderby’ parameter in versions up to, and including, 5.4.10 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with administrator-level or above permissions, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.



Vulnerability Details for Shopping Cart & eCommerce Store

Software Type Plugin
Software Slug wp-easycart (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.4.11, or a newer patched version
Affected Version
  • <= 5.4.10
Patched Version
  • 5.4.11

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.