WP Event Manager <= 3.1.22 - Admin+ Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-24810
CVSS 4.8 (Medium)
Publicly Published February 14, 2022
Last Updated November 7, 2022
Researcher Huy Nguyen


The WP Event Manager WordPress plugin before 3.1.23 does not escape some of its Field Editor settings when outputting them, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed



1 affected software package

Software Type Plugin
Software Slug wp-event-manager (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.1.23, or a newer patched version
Affected Version
  • <= 3.1.22
Patched Version
  • 3.1.23

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.