WP Express Checkout <= 2.2.8 - Authenticated (Admin+) Stored Cross-Site Scripting via pec_coupon[code]

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-1469
CVSS 4.4 (Medium)
Publicly Published March 17, 2023
Last Updated March 17, 2023
Researcher Ayoub Safa


The WP Express Checkout plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘pec_coupon[code]’ parameter in versions up to, and including, 2.2.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers with administrator-level access to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Note: This can potentially be exploited by lower-privileged users if the `Admin Dashboard Access Permission` setting it set for those users to access the dashboard.



Vulnerability Details for WP Express Checkout (Accept PayPal Payments Easily)

Software Type Plugin
Software Slug wp-express-checkout (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.2.9, or a newer patched version
Affected Version
  • 2.2.8 - 2.2.8
Patched Version
  • 2.2.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.