WP Fastest Cache <= 1.1.2 - Missing Authorization in 'wpfc_clear_cache_of_allsites_callback'

4.3
Missing Authorization
CVE CVE-2023-1930
CVSS 4.3 (Medium)
Publicly Published April 6, 2023
Last Updated April 7, 2023
Researcher Marco Wotschka - Wordfence

Description

The WP Fastest Cache plugin for WordPress is vulnerable to unauthorized data deletion due to a missing capability check on the wpfc_clear_cache_of_allsites_callback function in versions up to, and including, 1.1.2. This makes it possible for authenticated attackers with subscriber-level access to delete caches.

Wordfence blocked 908 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for WP Fastest Cache

Software Type Plugin
Software Slug wp-fastest-cache (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.1.3, or a newer patched version
Affected Version
  • <= 1.1.2
Patched Version
  • 1.1.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation