WP Fastest Cache <= 1.2.6 - Authenticated (Administrator+) Arbitrary File Deletion

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2024-4347
CVSS 7.2 (High)
Publicly Published May 10, 2024
Last Updated May 23, 2024
Researcher shaman0x01 - Shaman Red Team


The WP Fastest Cache plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 1.2.6 via the specificDeleteCache function. This makes it possible for authenticated attackers to delete arbitrary files on the server, which can include wp-config.php files of the affected site or other sites in a shared hosting environment.



Vulnerability Details for WP Fastest Cache

Software Type Plugin
Software Slug wp-fastest-cache (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.2.7, or a newer patched version
Affected Version
  • <= 1.2.6
Patched Version
  • 1.2.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.