WP Fusion Lite <= 3.41.24 - Authenticated (Contributor+) Remote Code Execution

Improper Control of Generation of Code ('Code Injection')
CVE CVE-2024-27972
CVSS 8.8 (High)
Publicly Published March 13, 2024
Last Updated March 20, 2024
Researcher LVT-tholv2k


The WP Fusion Lite – Marketing Automation and CRM Integration for WordPress plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 3.41.24. This makes it possible for authenticated attackers, with contributor-level access and above, to execute code on the server.



1 affected software package

Software Type Plugin
Software Slug wp-fusion-lite (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.42.10, or a newer patched version
Affected Version
  • <= 3.41.24
Patched Version
  • 3.42.10

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.