WP Google Map Plugin <= 4.4.2 - Cross-Site Request Forgery via delete()

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-28172
CVSS 5.4 (Medium)
Publicly Published March 13, 2023
Last Updated March 17, 2023
Researcher Rafie Muhammad - Patchstack


The WP Google Map Plugin plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 4.4.2. This is due to missing or incorrect nonce validation on the delete() function of the WPGMP_Model_Group_Map, WPGMP_Model_Location, and WPGMP_Model_Map classes. This makes it possible for unauthenticated attackers to delete a location, category, or map via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug wp-google-map-plugin (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.4.3, or a newer patched version
Affected Version
  • <= 4.4.2
Patched Version
  • 4.4.3

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.