WP MAPS – Easiest & Most Advanced WordPress Plugin for Google Maps <= 4.0.9 - Reflected Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVSS 6.1 (Medium)
Publicly Published September 21, 2019
Last Updated January 22, 2024


The WP MAPS – Easiest & Most Advanced WordPress Plugin for Google Maps plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the wp_ajax_fc_geocoding AJAX aciton in versions up to, and including, 4.0.9 due to insufficient input sanitization and output escaping on user supplied input. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.



Vulnerability Details for WP Maps – Display Google Maps Perfectly with Ease

Software Type Plugin
Software Slug wp-google-map-plugin (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.1.0, or a newer patched version
Affected Version
  • <= 4.0.9
Patched Version
  • 4.1.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.