WP Google Maps < 7.10.43 - Reflected Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2019-9912
CVSS 6.1 (Medium)
Publicly Published February 5, 2019
Last Updated January 11, 2023
Researcher Henri Salo (fgeek)


The wp-google-maps plugin before 7.10.43 for WordPress has XSS via the wp-admin/admin.php PATH_INFO.



Vulnerability Details for WP Go Maps (formerly WP Google Maps)

Software Type Plugin
Software Slug wp-google-maps (view on wordpress.org)
Patched? Yes
Remediation Update to version 7.10.43, or a newer patched version
Affected Version
  • <= 7.10.41
Patched Version
  • 7.10.43

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.