WPGraphQL <= 1.14.5 - Authenticated (Editor+) Server-Side Request Forgery

Server-Side Request Forgery (SSRF)
CVE CVE-2023-23684
CVSS 5.5 (Medium)
Publicly Published June 28, 2023
Last Updated January 22, 2024
Researcher Ravi Dharmawan


The WPGraphQL plugin for WordPress is vulnerable to Server-Side Request Forgery in versions up to, and including, 1.14.5 via createMediaItem. This can allow authenticated attackers with editor access or higher to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.



Vulnerability Details for WPGraphQL

Software Type Plugin
Software Slug wp-graphql (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.14.6, or a newer patched version
Affected Version
  • <= 1.14.5
Patched Version
  • 1.14.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.