WP Inventory Manager <= 2.1.0.13 - Cross-Site Request Forgery via delete_item

4.3
Cross-Site Request Forgery (CSRF)
CVE CVE-2023-2842
CVSS 4.3 (Medium)
Publicly Published June 5, 2023
Last Updated June 6, 2023
Researcher NGO VAN TU

Description

The WP Inventory Manager plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.1.0.13. This is due to missing or incorrect nonce validation on the delete_item function. This makes it possible for unauthenticated attackers to perform unauthorized actions via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. This is a possible duplicate of CVE-2023-34002.

References

Share

1 affected software package

Software Type Plugin
Software Slug wp-inventory-manager (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.1.0.14, or a newer patched version
Affected Version
  • <= 2.1.0.13
Patched Version
  • 2.1.0.14

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation