WP Job Portal <= 2.0.6 - Cross-Site Request Forgery

4.3
Cross-Site Request Forgery (CSRF)
CVE CVE-2023-52184
CVSS 4.3 (Medium)
Publicly Published December 29, 2023
Last Updated January 22, 2024
Researcher Nguyen Xuan Chien

Description

The WP Job Portal – A Complete Job Board plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.0.6. This is due to missing or incorrect nonce validation on an unknown function. This makes it possible for unauthenticated attackers to perform an unknown action granted they can trick a site administrator into performing an action such as clicking on a link. The impact of this vulnerability is unknown.

References

Share

Vulnerability Details for WP Job Portal – A Complete Job Board

Software Type Plugin
Software Slug wp-job-portal (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.0.7, or a newer patched version
Affected Version
  • <= 2.0.6
Patched Version
  • 2.0.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation