WP Meta SEO <= 4.5.3 - Cross-Site Request Forgery via 'setIgnore'

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-1028
CVSS 4.3 (Medium)
Publicly Published February 24, 2023
Last Updated February 28, 2023
Researcher Marco Wotschka - Wordfence


The WP Meta SEO plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 4.5.3. This is due to missing or incorrect nonce validation on the setIgnore function. This makes it possible for unauthenticated attackers to update plugin options via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for WP Meta SEO

Software Type Plugin
Software Slug wp-meta-seo (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.5.4, or a newer patched version
Affected Version
  • <= 4.5.3
Patched Version
  • 4.5.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.