WP Meta SEO <= 4.5.4 - Authenticated (Author+) PHAR Deserialization

Deserialization of Untrusted Data
CVE CVE-2023-1381
CVSS 8.8 (High)
Publicly Published March 27, 2023
Last Updated March 29, 2023
Researcher Alex Sanford


The WP Meta SEO plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 4.5.4 due to insufficient file path validation that makes it possible for attackers to supply paths to files with a phar:// wrapper that will unserialize during retrieval. This makes it possible for authenticated attackers, with author-level permissions and above, to inject a PHP Object. The plugin does contain a useable gadget chain that may make remote execution possible.



1 affected software package

Software Type Plugin
Software Slug wp-meta-seo (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.5.5, or a newer patched version
Affected Version
  • <= 4.5.4
Patched Version
  • 4.5.5

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.