WordPress Backup & Migration <= 1.4.8 - Missing Authorization to Directory Traversal

Missing Authorization
CVE CVE-2024-3546
CVSS 4.3 (Medium)
Publicly Published April 22, 2024
Last Updated May 2, 2024
Researcher Krzysztof Zając - CERT PL


The WordPress Backup & Migration plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the wp_mgdp_populate_popup function in all versions up to, and including, 1.4.8. This makes it possible for authenticated attackers, with subscriber access or above, to invoke this function and access log files maintained by the plugin. Additionally, the file name is user-provided and not properly sanitized, which allows attackers to read arbitrary log files on the file system.



Vulnerability Details for WebToffee WP Backup and Migration

Software Type Plugin
Software Slug wp-migration-duplicator (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.4.9, or a newer patched version
Affected Version
  • <= 1.4.8
Patched Version
  • 1.4.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.