Multisite Content Copier/Updater <= 1.4.0 - Reflected Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-25039
CVSS 6.1 (Medium)
Publicly Published February 7, 2022
Last Updated August 8, 2022
Researcher Asif Nawaz Minhas - Patchstack Alliance


The WordPress Multisite Content Copier/Updater WordPress plugin before 1.5.0 does not sanitise and escape the wmcc_content_type, wmcc_source_blog and wmcc_record_per_page parameters before outputting them back in attributes, leading to Reflected Cross-Site Scripting issues



Vulnerability Details for WordPress Multisite Content Copier/Updater

Software Type Plugin
Software Slug wp-multisite-content-copier (view on
Patched? Yes
Remediation Update to version 1.5.0, or a newer patched version
Affected Version
  • <= 1.4.0
Patched Version
  • 1.5.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.