WP Post Author <= 3.2.3 - Privilege Escalation

9.8
Improper Privilege Management
CVSS 9.8 (Critical)
Publicly Published June 28, 2023
Last Updated January 22, 2024

Description

The WP Post Author plugin for WordPress is vulnerable to privilege escalation in versions up to, and including, 3.2.3. This is due to insufficient controls on the /set-user-data REST API endpoint. This makes it possible for authenticated attackers to set their user role to administrator and gain complete access to the site. Attackers can easily obtain authenticated access using the /v1/frontend/register-user REST API endpoint, even when registration is disabled on the site.

References

Share

Vulnerability Details for Enhance Your Posts with the WP Post Author Box, Co-Authors, Guest Authors, and Post Rating System, including Registration Form Builder

Software Type Plugin
Software Slug wp-post-author (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.3.0, or a newer patched version
Affected Version
  • <= 3.2.3
Patched Version
  • 3.3.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation