WP Recipe Maker <= 9.2.1 - Authenticated Stored Cross-Site Scripting via Video Embed

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)
CVE CVE-2024-1571
CVSS 4.4 (Medium)
Publicly Published March 14, 2024
Last Updated April 9, 2024
Researcher Sh


The WP Recipe Maker plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Video Embed parameter in all versions up to, and including, 9.2.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with access to the recipe dashboard (which is administrator-only by default but can be assigned to arbitrary capabilities), to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for WP Recipe Maker

Software Type Plugin
Software Slug wp-recipe-maker (view on wordpress.org)
Patched? Yes
Remediation Update to version 9.3.0, or a newer patched version
Affected Version
  • <= 9.2.1
Patched Version
  • 9.3.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.