WP Remote Users Sync <= 1.2.12 - Authenticated (Subscriber+) Server Side Request Forgery

Server-Side Request Forgery (SSRF)
CVE CVE-2023-3958
CVSS 8.5 (High)
Publicly Published August 15, 2023
Last Updated January 22, 2024
Researcher István Márton - Wordfence


The WP Remote Users Sync plugin for WordPress is vulnerable to Server Side Request Forgery via the 'notify_ping_remote' AJAX function in versions up to, and including, 1.2.12. This can allow authenticated attackers with subscriber-level permissions or above to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services. This was partially patched in version 1.2.12 and fully patched in version 1.2.13.



Vulnerability Details for WP Remote Users Sync

Software Type Plugin
Software Slug wp-remote-users-sync (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.2.13, or a newer patched version
Affected Version
  • <= 1.2.12
Patched Version
  • 1.2.13

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.