WP Replicate Post <= 4.0.2 - Authenticated (Contributor+) SQL Injection

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2023-2237
CVSS 8.8 (High)
Publicly Published May 10, 2023
Last Updated June 9, 2023
Researcher Marco Wotschka


The WP Replicate Post plugin for WordPress is vulnerable to SQL Injection via the post_id parameter in versions up to, and including, 4.0.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for contributor-level attackers or higher to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.



1 affected software package

Software Type Plugin
Software Slug wp-replicate-post (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.1, or a newer patched version
Affected Version
  • <= 4.0.2
Patched Version
  • 4.1

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.